• Login
  • Register

DNN Forums

A community discussion page. We're starting from scratch, so...let's get the party started!

After upgrading to dnn 9.6.1, started getting issue "bootstrap's javascript requires jquery version 1.9.1 or higher but lower than 3"

You are not authorized to post a reply.
Sort:


New Member


Posts:6
New Member

    Hi All,

    I have upgrade my DNN site from 8.0.1 to 9.6.1 version and it was successful. After the upgrade I was getting error as "bootstrap's javascript requires jquery version 1.9.1 or higher but lower than 3" and because of this error the JQuery was not running and so UI controls.

    To resolved above error, I replaced the upgraded Jquery files with older ones in all the 3 folders (JQuery, Jquery Migrate and Jquery UI) under "~/Resources/Libraries". After that it started working withut showning mentioned error.

    I am not sure whether this is proper way or not. Also I am not sure if this hack will lead me to any other problem. Can anyone please guide me here for the correct way to resolve this issue with steps?



    Veteran Member


    Posts:333
    Veteran Member

      Maya,

      It looks like one of the modules or the skin/theme you use is in need of this old jQuery version. I would recommend to find out which it is and ask the vendor for an update.

      Happy DNNing!
      Michael

      Michael Tobisch
      DNN★MVP

      dnnWerk Austria
      DNN Usergroup für den deutschsprachigen Raum
      DNN Connect


      Veteran Member


      Posts:483
      Veteran Member

        Can you tell us the steps you used to go from 8.0.1 to 9.6.1? Did you follow the suggested upgrade path, or did you go in a single step?

        There are several places in the 9.x series of releases that create breaking changes. For you, 9.6.0 changed the included jQuery library. Check out the release notes for that release for a link to jQuery's upgrade guide.

        Since the message you received came from Bootstrap, the likeliest source of the problem is in your Theme, or a module that loads Bootstrap. The "correct" way to fix this is to find and upgrade the source of the problem. If it's a purchased theme or module, see if there is an update compatible with DNN 9.6.1. If it's custom, go to the developer.

        You hack will have to be repeated every time you upgrade DNN, so it's better to find a different approach.
        Joe Craig
        DNN MVP
        Patapsco Research Group


        New Member


        Posts:6
        New Member

          Hi Joe,

          I have directly upgraded from 8.0.1 to 9.6.1 as it was mentioned somewhere in an article that we can upgrade in a single go from any 8.x to 9.x version. Do you think direct upgrade is creating such issue?



          Veteran Member


          Posts:562
          Veteran Member

            Posted By Maya Trivedi on 25 Jun 2020 06:39 AM

            Hi All,

            I have upgrade my DNN site from 8.0.1 to 9.6.1 version and it was successful. After the upgrade I was getting error as "bootstrap's javascript requires jquery version 1.9.1 or higher but lower than 3" and because of this error the JQuery was not running and so UI controls.

            To resolved above error, I replaced the upgraded Jquery files with older ones in all the 3 folders (JQuery, Jquery Migrate and Jquery UI) under "~/Resources/Libraries". After that it started working withut showning mentioned error.

            I am not sure whether this is proper way or not. Also I am not sure if this hack will lead me to any other problem. Can anyone please guide me here for the correct way to resolve this issue with steps?

            AFAIK Bootstrap 3.3.7 support jQuery 3. So I would upgrade the Theme to use at least BS 3.3.7 (also contains a security fix)

             

             



            New Member


            Posts:6
            New Member

              Yes, I have updated bootstrap and with the updated bootstrap JQuery is not giving error as mentioned.

              But new issue came up is --> After some time the DNN site pages are giving error while loading this pages again. Error is coming in Jquery.js while loading the settings of the DNN site page.

              Anyone can help me with this error?



              Veteran Member


              Posts:483
              Veteran Member

                Can you provide any details on the js errors?
                Joe Craig
                DNN MVP
                Patapsco Research Group


                Veteran Member


                Posts:562
                Veteran Member

                  Posted By Maya Trivedi on 29 Jun 2020 11:33 AM

                  Yes, I have updated bootstrap and with the updated bootstrap JQuery is not giving error as mentioned.

                  But new issue came up is --> After some time the DNN site pages are giving error while loading this pages again. Error is coming in Jquery.js while loading the settings of the DNN site page.

                  Anyone can help me with this error?

                  Next step would be to see if this also occurs with the default DNN theme (Xcillion).
                  If not, it's Theme related..

                   

                   



                  New Member


                  Posts:6
                  New Member

                    Hi All,

                    All the issue was with .net framework. I updated .net framework 4.8.* and everything worked as expected. Thank you all for your response.

                    You are not authorized to post a reply.

                    These Forums are dedicated to discussion of DNN Platform.

                    For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

                    1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
                    2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
                    3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
                    4. No Flaming or Trolling.
                    5. No Profanity, Racism, or Prejudice.
                    6. Site Moderators have the final word on approving / removing a thread or post or comment.
                    7. English language posting only, please.

                    Would you like to help us?

                    Awesome! Simply post in the forums using the link below and we'll get you started.

                    Get Involved