• Login
  • Register

DNN Forums

A community discussion page. We're starting from scratch, so...let's get the party started!

PDF files corrupt on Repository module after upgrade

You are not authorized to post a reply.
Sort:


New Member


Posts:18
New Member

    We have just upgraded our repository module from 4.0 to 4.1 (and upgraded DNN too) and most of our PDF documents no longer open.

    we get an Adobe error saying:
           "There was an error opening this document. The file is damaged and could not be repaired"

    Some PDFs do open but most do not.

    We are on DNN 9.6.1 ( we have recently done several upgrades from 7.4.2 but have been checking all modules along the way and the Repository did appear to work in other DNN versions. We don't really want to go backwards in DNN platform incase it's a security risk).

     

    Is there a fix for this? or is the only way to re-upload the files? (could be over 200).

    thanks.

     



    Veteran Member


    Posts:596
    Veteran Member

      Posted By sypa on 30 Jul 2020 05:27 AM

      We have just upgraded our repository module from 4.0 to 4.1 (and upgraded DNN too) and most of our PDF documents no longer open.

      we get an Adobe error saying:
             "There was an error opening this document. The file is damaged and could not be repaired"

      Some PDFs do open but most do not.

      We are on DNN 9.6.1 ( we have recently done several upgrades from 7.4.2 but have been checking all modules along the way and the Repository did appear to work in other DNN versions. We don't really want to go backwards in DNN platform incase it's a security risk).

       

      Is there a fix for this? or is the only way to re-upload the files? (could be over 200).

      thanks.

       

      I don't expect that the upgrade really corrupted the files TBH.
      Can you acees them directly? (or are they in a secured folder..?)
      Anyway, I guess it's better to (also) post this issue @ https://github.com/DNNCommunity/DNN.Repository

       

       



      New Member


      Posts:18
      New Member

        we have just re-mapped them by deleting repository 4.1 re-installing repository 4.0 (which is more stable) and recreated a new module on each page (24 in total) and then re-assigned the appropriate module ID from the new module to the existing records.



        New Member


        Posts:18
        New Member

           another repository issue - it forces a description to be inserted for every repository. we've never had one before so this is a suprise and annoying because we really don't want one and now all users see an ADMIN notice!
           

          ADMIN: Select Repository Settings from the Module Settings drop down menu to set the Repository Description text as well as set the number of objects to be displayed on each page.

           

          - update - i've managed to remove the above message now in repository/app_localresources/repository.ascx.resx



          Veteran Member


          Posts:596
          Veteran Member

            Posted By sypa on 30 Jul 2020 11:30 AM

             another repository issue - it forces a description to be inserted for every repository. we've never had one before so this is a suprise and annoying because we really don't want one and now all users see an ADMIN notice!
             

            ADMIN: Select Repository Settings from the Module Settings drop down menu to set the Repository Description text as well as set the number of objects to be displayed on each page.

             

            - update - i've managed to remove the above message now in repository/app_localresources/repository.ascx.resx

            Please log these issues on the github repo I mentioned before.

             

             



            New Member


            Posts:18
            New Member

              Posted By Timo Breumelhof on 30 Jul 2020 12:07 PM
              Posted By sypa on 30 Jul 2020 11:30 AM

               another repository issue - it forces a description to be inserted for every repository. we've never had one before so this is a suprise and annoying because we really don't want one and now all users see an ADMIN notice!
               

              ADMIN: Select Repository Settings from the Module Settings drop down menu to set the Repository Description text as well as set the number of objects to be displayed on each page.

               

              - update - i've managed to remove the above message now in repository/app_localresources/repository.ascx.resx

              Please log these issues on the github repo I mentioned before.

               

               

              ok - i've reported the issue.

               

              thanks.

               

               

               

              You are not authorized to post a reply.

              These Forums are dedicated to discussion of DNN Platform.

              For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

              1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
              2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
              3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
              4. No Flaming or Trolling.
              5. No Profanity, Racism, or Prejudice.
              6. Site Moderators have the final word on approving / removing a thread or post or comment.
              7. English language posting only, please.

              Would you like to help us?

              Awesome! Simply post in the forums using the link below and we'll get you started.

              Get Involved