• Login
  • Register

DNN Forums

A community discussion page. We're starting from scratch, so...let's get the party started!

Friendly URLs Not Working in 8.0.4

You are not authorized to post a reply.
Sort:


New Member


Posts:3
New Member

    Hi

    I am trying to upgrade a website from 6.2.9 to 9.7.*

    I have upgraded to 7.0.0 and then to 7.4.2 fine and the website works just as it did.

    I had all sorts of issues trying to upgrade to 8.0.4 with lots of error including:

    Could not load type DotNetNuke.HttpModules.Config.RewriterRule Collection' from assembly 'DotNetNuke.HttpModules, Version=8.0.4.226, Culture=neutral, PublicKeyToken=null.

    So in version 7.4.2 I removed TanLD rewriter completely and got the site working without friendly URLs, just tabids. I then upgraded to 8.0.4 and the site still works just as it did in 7.4.2, without friendly rewriting and with tabids in the URLs.

    Now though if I try to enable Use Friendly URLs I get the following:

    • Website pages display fine without the tabids in the URL but with the file name extension in capitals as the page names are.
    • Admin pages display, again with the file name extension, e.g. .../Admin/Pages.aspx.
    • Host pages give 404, URL e.g. .../Host/FileManagement/tabid/122/portalid/0/  looking for file: \Host\FileManagement\tabid\122\portalid\0\

    I've been trying to go through the web.config in detail, comparing it to what a clean install of 8.0.4 would have installed and there are many differences, but I'm not exactly sure what I'm looking for. The rewriting sections are the same though.

    Any help would be much appreciated.



    Veteran Member


    Posts:684
    Veteran Member

      Set the URL type to "advanced" in web.config.
      Joe Craig
      DNN MVP
      Patapsco Research Group


      New Member


      Posts:3
      New Member

        Thanks so much Joe, that works a treat.

        Just one more query of that's OK. Do I need to install an Extension URL Provider to force the friendly URLs to lowercase? Or, is there a tweak to the DNNFriendlyUrl web.config entry that will do the trick?

        Many thanks again.



        New Member


        Posts:3
        New Member

          I have since upgraded to 9.1.1 and the option to force to lowercase is now in there.

          You are not authorized to post a reply.

          These Forums are dedicated to discussion of DNN Platform.

          For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

          1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
          2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
          3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
          4. No Flaming or Trolling.
          5. No Profanity, Racism, or Prejudice.
          6. Site Moderators have the final word on approving / removing a thread or post or comment.
          7. English language posting only, please.

          Would you like to help us?

          Awesome! Simply post in the forums using the link below and we'll get you started.

          Get Involved