• Login
  • Register

DNN Forums

A community discussion page. We're starting from scratch, so...let's get the party started!

PersonaBar errors

You are not authorized to post a reply.
Sort:
Page 2 of 2 << < 12


Veteran Member


Posts:746
Veteran Member

    Ok, I think I posted the wrong folder, sorry about that.

      /DesktopModules/Admin/Dnn.PersonaBar/Resources is the correct one



    New Member


    Posts:6
    New Member

      One of the two problems is solved. It was clear that the problem has to do with an attempt to populate UserProperties and Barry Walusko from Glanton spotted that shouldn't be the case for superusers. It required a change in Dotnetnuke.dll (specific a particular build for 9.1.1) to stop those properties being loaded.

      However the problem of not being able to upgrade from DNN 9.1.1 remains. It specifically affects the PersonaBar. The EditBar.UI and PersonaBar.UI components install fine. However the other elements (which in later DNN versions are grouped into one component 'Extensions' ) will not load. The error message when trying to load the DNN 9.2.1 AdminLogs component (for example) using DNN 9.1.1 and the installation routine (to get maximal feedback - the logs aren't much help) is "Failure Error creating component installer.":

      StartJob Reading files
      Info File bin\Dnn.PersonaBar.AdminLogs.dll read successfully
      Info File Dnn.PersonaBar.AdminLogs.dnn read successfully
      Info File license.txt read successfully
      Info File releaseNotes.txt read successfully
      Info File Resources.zip read successfully
      EndJob Reading files done.
      StartJob Reading Installation Manifest file
      Info Reading Package Manifest - PersonaBar - Dnn.PersonaBar.AdminLogs
      Info Reading Component Manifest - ResourceFile
      Info Found valid path () for Resources.zip.
      Info Found valid path () for Resources.zip.
      Info Reading Component Manifest - Assembly
      Info Found valid path (bin) for Dnn.PersonaBar.AdminLogs.dll.
      Info Reading Component Manifest - PersonaBarMenu
      Failure Error creating component installer.

      All the other PersonaBar produce the same error. Nothing modules outside the PersonaBar produce an error when installing.The only thing I can think of is that we've upgraded .Net so it is compatible with DNN 9.4 and above. Installing DNN 9.3.2 (same problem) 9.4.4 (Error: requires DNN 9.3.0 before can be installed) all fail in the same elements or in the new PersonaBar.Extensions grouped module.

      I can't see any report of people having this problem.

      Does anyone have any insights into this? Thanks in advance.

      You are not authorized to post a reply.
      Page 2 of 2 << < 12

      These Forums are dedicated to discussion of DNN Platform.

      For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

      1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
      2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
      3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
      4. No Flaming or Trolling.
      5. No Profanity, Racism, or Prejudice.
      6. Site Moderators have the final word on approving / removing a thread or post or comment.
      7. English language posting only, please.

      Would you like to help us?

      Awesome! Simply post in the forums using the link below and we'll get you started.

      Get Involved