• Login
  • Register

DNN Forums

A community discussion page. We're starting from scratch, so...let's get the party started!

InstallWizard woes

You are not authorized to post a reply.
Sort:


New Member


Posts:7
New Member

    Background: I'm attempting to install DNN platform on a shared host; ie. no remote access, no IIS manager, just ftp and Hsphere control panel. The host is already running a .net site which includes YAF, so I'm putting dnn in a subfolder, which I've set up as a web app with a dedicated app pool.

    I've extracted DNN_Platform_9.3.2.24_Install.zip to the dnn folder and prepared an empty database.

    1st issue: InstallWizard.aspx won't load with the app pool in integrated mode, only in classic mode. But when installing, it then gives the error ERROR occured - AppPool in IIS must run under Integrated Mode

    Changing the app pool to Integrated after loading InstallWizard.aspx doesn't work as Continue then does nothing.

    So I edited dnn\web.config to remove modules EditBar, PersonaBar and RadUpload. InstallWizard then loads in Integrated mode. But InstallWizard then fails during Database Installation 31pc with ERROR:Value cannot be null. Parameter name: type.

    I've also tried a lot more, but cannot get it to install and am about to give up!

    It installed fine on my dev machine; would it work uploading that database and files, amending web.config as required?

    PS. Why is this editor garbling my message?

    PPS. Where's the InstallWizard source?

     

     

     



    New Member


    Posts:7
    New Member

      I've now tried using Install.aspx rather than InstallWizard.aspx, but just got "Error" on every "Installing package file" line.



      Basic Member


      Posts:55
      Basic Member

        DNN requires Integrated Mode, that's for sure. Basic steps for installing are:
        1. Create empty DB
        2. Unzip install zip into the folder in which DNN will "live". Be sure that this folder has the permissions that DNN requires.
        3. Set the web pointing to that folder
        4. Just run in the browser the URL for your DNN (no install, wizard, etc). Installation should begin; you'll have to fill some basic data for host user and DB connection.
        5. Installation shouldn't take more than a couple of minutes.

        I hope this helps ;-)


        New Member


        Posts:7
        New Member

          Thanks for replying, but you missed this bit " InstallWizard.aspx won't load with the app pool in integrated mode, only in classic mode"

          Anyway, I've now uploaded my local site and database; it's sort of running, but no persona bar so I can't do anything!



          Basic Member


          Posts:55
          Basic Member

            I can't understand that error. I've installed a lot of DNN's all on integrated mode. I can't remember last time I ran DNN on classic...

            Maybe something about pool permissions.



            New Member


            Posts:7
            New Member

              OK, I give up. All I can get is the default blank website page. When I login as superuser there's no persona bar.
              Nothing useful in Portals/_default/Logs, browser console shows these errors:

              HTTP404: NOT FOUND - The server has not found anything matching the requested URI (Uniform Resource Identifier).
              GET - http://www.xxxxx.xxx.xx/dnn/ScriptResource.axd?d=NJmAwtEo3IoPxNT43GKQlXZeh9Y6kBYRPi7wGolSTzTcVjd9HUXkkHfcxfOxWN7_h-9C5kVE5C1LeZdROUQkvh2TK5yn9CkGq7dj257V9hdSGiL2-t47MTwypemZZvO2M9pcNw2&t=ffffffffa580202a
              and

              SCRIPT5009: SCRIPT5009: 'Sys' is not defined

              So a problem with jQuery? Any ideas?


              New Member


              Posts:7
              New Member

                I have a working site, after adding a ScriptResource.axd handler to dnn's web.config.  I guess the ScriptResource.axd requests weren't getting through
                Hurrah!



                Veteran Member


                Posts:312
                Veteran Member

                  Glad you got this figured out, but it certainly shouldn't have been that difficult, nor should it have required any manual intervention by yourself (as you described). I would personally be cautious moving forward regarding your web host. I'm wondering if they have and are keeping up with .NET/Windows updates and whether their server configuration is too restrictive for an application like DNN. :(
                  Will Strohl

                  Upendo Ventures Upendo Ventures
                  DNN experts since 2003
                  Official provider of the Hotcakes Commerce Cloud and SLA support
                  You are not authorized to post a reply.

                  These Forums are dedicated to discussion of DNN Platform.

                  For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

                  1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
                  2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
                  3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
                  4. No Flaming or Trolling.
                  5. No Profanity, Racism, or Prejudice.
                  6. Site Moderators have the final word on approving / removing a thread or post or comment.
                  7. English language posting only, please.

                  Would you like to help us?

                  Awesome! Simply post in the forums using the link below and we'll get you started.

                  Get Involved