• Login
  • Register

DNN Forums

A community discussion page. We're starting from scratch, so...let's get the party started!

DNN upgrade to 9.4.4 and Telerik controls

You are not authorized to post a reply.
Sort:
Page 1 of 212 > >>


New Member


Posts:6
New Member

    We have a huge website which is currently running on DNN v9.1.1 , I am trying to upgrade it to 9.4.4. I got the upgrade package extracted and copied on the website and tried to upgrade the site. I got the following error:

    Server Error in '/' Application.


    Compilation Error

    Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

    Compiler Error Message: BC30456: 'Synchronize' is not a member of 'DotNetNuke.Common.Utilities.FileSystemUtils'.

    Source Error:

     

     
    
    Line 23: 		Private Sub SyncDBandFolders()
    Line 24: 			If (objPortalSettings.ActiveTab.ParentId = objPortalSettings.SuperTabId) Then
    Line 25: 				DotNetNuke.Common.Utilities.FileSystemUtils.Synchronize(DotNetNuke.Common.Utilities.Null.NullInteger, DotNetNuke.Common.Utilities.Null.NullInteger, DotNetNuke.Common.Globals.HostMapPath)
    Line 26: 			Else
    Line 27: 				DotNetNuke.Common.Utilities.FileSystemUtils.Synchronize(objPortalSettings.PortalId, objPortalSettings.AdministratorRoleId, objPortalSettings.HomeDirectoryMapPath)


    Source File: C:\DNN-Upgrade\DotNetNuke\App_Code\TelerikWebUI\RadEditorProvider.vb    Line: 25

     

    Show Detailed Compiler Output:

     

    Show Complete Compilation Source:


     


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.8.3928.0

    On searching futher I saw this post https://dnncommunity.org/forums/aft/215, which says the RadEditor provider is removed. Our site uses telerik controls heavily. I counted 40+ uses of RadEditor alone.

    1. Is RadEditor is the only one not usable or all the telerik controls? we use a lot of telerik controls.
    2. We have a license for Telerik. Can I still use RadEditor? If so, how?
    3. If we need to switch RadEditor to CKEditor, is there a step-by-step guide?
    4. We are still using some deprecated methods that were removed in 9.2. Do I need to remove the deprecated calls before I can upgrade? Does the upgrade fail if I don't remove them before the upgrade? I understand that the site will not be usable but I am trying to figure out upgrade first and then fix the code or fix the code and then upgrade.
    5. Are there any other things I need to be concerned when upgrading from 9.1.1 to 9.4.4

     

     



    Basic Member


    Posts:84
    Basic Member

      You need to uninstall Rad Editor Providor and switch to the DNNConnect editor providor. After that you should be able to upgrade

      DNN Technology Team | Area Lead Testing


      Basic Member


      Posts:45
      Basic Member

        1. Is RadEditor is the only one not usable or all the telerik controls? we use a lot of telerik controls.

          The Telerik controls are still available, but will be removed by DNN 10. However, you may still use your licensed version of the Telerik controls in your custom extensions.

        2. We have a license for Telerik. Can I still use RadEditor? If so, how?

          I believe you would need to create your own HTML editor provider with your licensed controls. This would include creating the DNN integrations, like the file explorer.

        3. If we need to switch RadEditor to CKEditor, is there a step-by-step guide?

          You should be able to just switch the default provider listed in the web.config and CKEditor will start being used. Then uninstall the RadEditor Provider.

        4. We are still using some deprecated methods that were removed in 9.2. Do I need to remove the deprecated calls before I can upgrade? Does the upgrade fail if I don't remove them before the upgrade? I understand that the site will not be usable but I am trying to figure out upgrade first and then fix the code or fix the code and then upgrade.

          I would suggest compiling against DNN 9.1.1, which will show you warnings about usages of deprecated methods (included suggested changes to make). Then you can run your upgrade.

        5. Are there any other things I need to be concerned when upgrading from 9.1.1 to 9.4.4
          • From 9.4.0 release notes
            If you have custom modules that use DAL2 with primary keys that are not auto-incremented, the module code will need to be validated to explicitly indicate that since the default behaviour for primary keys in the latest PetaPOCO has changed.
          • From 9.3.1 release notes
            If you currently use any 3rd party or in-house Persona Bar extensions which utilize the export bundle from the Admin Experience, they will need to be updated after upgrading to v9.3.1. Please see the Additional Resources section below for more information on this change.
          • The 9.2.0 release notes have a long list of potentially breaking changes
        DNN partner specializing in custom, enterprise DNN development https://engagesoftware.com/showcase


        Advanced Member


        Posts:134
        Advanced Member

          And...if you use DNN Sharp there are 2 things:
          1. There is a NewtonSoft patch on their website which is needed.
          2, You can not upgrade to 9.4.x currently as their modules have not upgraded. So, 9.3.2. would be the max.

          In general:
          - remove modules you don't use
          - review if you use modules that are maintained. If you use anything older than - say - 2 years, think if you can still trust the quality/security.
          - upgrade modules to the latest current versions
          - Newtonsoft patch (if needed)
          - Install CKeditor (DNN Connect version), switch to CKeditor, Uninstall Radedtor
          - Upgrade DNN
          Tjep's digital agencyRegards,
          Tycho de Waard

          Tjep's digital agency
          We just love DNN
          https://www.tjeps.com


          New Member


          Posts:6
          New Member

            Thank you so much for replying and providing lot of useful information!

            I have not created a provider so far. What is involved? are there any documenataion or any articles that can provide guidence? 

            You said "This would include creating the DNN integrations, like the file explorer.". Sorry, I don't understand what are DNN integrations? Is File explorer for RadEditor or Rad File upload or something else? 

            If we decide to go with CKEditor, other than changing the default provider what need to be done for custom modules that use RadEditor? Other than changing the tags on ascx files and adjusting any API calls, is there anything else need to be done?

             

             

            You are not authorized to post a reply.
            Page 1 of 212 > >>

            These Forums are dedicated to discussion of DNN Platform.

            For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

            1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
            2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
            3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
            4. No Flaming or Trolling.
            5. No Profanity, Racism, or Prejudice.
            6. Site Moderators have the final word on approving / removing a thread or post or comment.
            7. English language posting only, please.

            Would you like to help us?

            Awesome! Simply post in the forums using the link below and we'll get you started.

            Get Involved