• Login
  • Register

DNN Blogs

Written for the Community, by the Community

DNN 09.06.00, jQuery 3.5.0 and Bootstrap / jQuery plugin issues

Written By Timo Breumelhof
2020-05-06

Now that DNN 09.06.01 is out you should just uprade to that version, if fixes the jQuery issues.

I really like that DNN is updating the used libraries more actively than before.
The DNN 09.06.00 Release comes with the latest jQuery; version 03.05.00
Unfortunately there's a change in jQuery 03.05.00 that makes some JavaScript Libraries fail, one of them being the "Collapse" functionality in Bootstrap. Read more in this Github issue
There is already a new release of jQuery: 03.05.01 which repairs the issue.

https://blog.jquery.com/2020/05/04/jquery-3-5-1-released-fixing-a-regression/

But that does not fix the issue in DNN (jQuery 03.05.01 will be part of the upcoming DNN 09.06.01 release).

So if you do want to upgrade to DNN 09.06.00 now because of security, here's a quick hack to fix the issue (at least for now).
FYI, In theory you should be able to add a custom CNS for the jQuery version and force DNN to load jQuery 3.5.1 from a CDN, but on my installations that did not work.

<edit>I just found out that you can also install jQuery 05.03.01 in DNN 09.06.00 using this package, that alone should fix the issue too. For more information see Brians comment below</edit>

So I downloaded https://code.jquery.com/jquery-3.5.1.js

And I copied it's content into the "\Resources\Libraries\jQuery\03_05_00\jquery.js" file.
That's something you normally should not do, change core files, but as jQuery 03.05.01 is on its way, it's an acceptable hack for me.

The skin I tested did not use bootstrap but another plugin that stopped working (cycle2) with the same error and it's now works again.

Total: 2 Comment(s)
DNN 9.6.1 will come with jQuery 3.5.1. You can download a nightly build (e.g. https://dev.azure.com/dotnet/DNN/_build/results?buildId=32507&view=artifacts) and grab jQuery.zip from the /Install/JavaScriptLibrary folder, and install it into your DNN 9.6.0 site (we also have a version available at https://ci.appveyor.com/api/buildjobs/c1bvvcw9mn72gtd4/artifacts/_InstallPackages%2Fjquery_3.5.1.zip)
Wednesday, May 6, 2020 ·
I've tested this workaround and it seems to work with Xcillion theme. Just installed JQuery 3.5.1 extension and bootstrap collapse is back :-)
Thursday, May 7, 2020 ·

Would you like to help us?

Awesome! Simply post in the forums using the link below and we'll get you started.

Get Involved