DNN Forums

Ask questions about your website to get help learning DNN and help resolve issues.

DNN 9.8 dnnModuleManager

You are not authorized to post a reply.

New Around Here

    Upon upgrading a dnn 9.3 to 9.8 an unexpected issue seems to have turned up on a consistent basis. Anytime some content manager tries to add a module the floating icon never turns up and remains invisible until Personabar > host> empty cache has been clicked.

    The moment the new module is added, these messages turn up in the developer bar console tab:
    Uncaught TypeError: Cannot read property 'options' of undefined
        at dnn.dnnModuleDialog.apply (js:272)
        at handleNewModuleFromCookie (js:377)

    The attached screen prints are related to the above lines, 272 and 377.

    What makes this error difficult is the fact that it only occurs when the concerned page has this setting: Display in menu = true.
    If Display in menu = false then this problem disappears. 

    In case of adding a new tab/page and deploying the same ascx template is in the above example it will work without errors. 

    Since the website contains a lot of pages the problem with the js dnn moduleManager represents quite a hassle.

    Anyone with similar experiences? And thanks for your attention.



    Veteran Member

      You might want to take a look at the logs in portals/_default/logs.

      For debugging, you might increate the logging level.

      Joe Craig
      DNN MVP
      Patapsco Research Group

      Veteran Member

        The error seems to appear once in a while but every time in context of bad html:
        - https://www.dnnsoftware.c...e/posts/threadpage/2 : old theme with tables.
        - third party module not closing a div: https://github.com/dnnsof...Platform/issues/3407

        One more thing: As your error points to cookies and you mention 9.8....I remembered an issue with cookies that was solved for 9.8.1: https://github.com/dnnsof...Platform/issues/4308
        Tjep's digital agencyRegards,
        Tycho de Waard

        Tjep's digital agency
        We just love DNN

        New Around Here

          Thanks for your advice on the subject - I have been through the log files with a log4net setting of 'All' but apparently this type of Javascript error isn't registered at the backend level.
          Since the pages are created using a template containing preembedded and empty Live Html modules it could be that some kind of 'bad html error' since the markup tends to somewhat complicated.
          Another thing to mention regarding this issue is the fact that when adding a new module on a page deploying the errorprone template the module in question will not be visible before emptying the cache. So I guess updating dnn would be worthwhile

          New Around Here

            Some further investigation in this issue reveals that the problem arises, regardless of the chosen skin, but depends upon whether the page/tab in question has been added by means of apage template that was created with the option 'Include content' turned on.
            That makes it three different factors having to be present in order to make the error occur:
            Client Resource Management must be turned on
            The page in question must visible in the menu
            The page must be have been created from a dnn template utilizing the option 'Include content'

            As mentioned earlier, this error appeared first time after upgrading to dnn 9.8 and I have seen in the changelog of the latter that a bug related to inserting af new module has been fixed as described in this url:
            It isn't exactly the same error, but both relate to the utilization of cookies in order to insert a new module. The inserted module in my case always ends up in the default contentPane and becomes visible once the dnn server cache has been emptied.
            I pretend the problem could be related to the state of the recycle bin as this one is rarely if ever emptied and contains hundreds of soft deleted tabs and modules since it tends to occur on tabs having a specific parent page

            Veteran Member

              I have had a similar issue and it was also related to HTML errors in the content of the placed module.
              I would try uisng an HTML validator on the page after you cleared the Cache to see if that might be the case.

              New Around Here

                Thanks, but I don't think it is a question of bad html within the module that I am trying to add to the page in question since the problem is not related to a specific module but rather to a specific state of the page upon which I try to add a new module.

                At this time I have tried with two different modules a custom made and a commercial one, Live Tabs from Mandeeps, both turned out the same way.  But taking your advice I will try out with a couple of other commercial dnn modules like EasyDNNNews for instance and see whether that changes the procedure.

                Veteran Member

                  It can also be caused by a module that's already on the page

                  New Around Here

                    Thanks for making that suggestion,but I have just verified that any bad html in modules existing on the page cannot be the cause of this issue.

                    If I add a new page called SubPageA based on a specific template to a specific page called ParentPageX I can then add a new module to SubPageA without any problem, but if I add a new page called SubPageB to another parent page called ParentPageY the problem will be present. If I then move SubPageB to to ParentPageX the problem will disappear.

                    This seems to indicate that a condition related to the page tree is involved but I can't figure out how and why this could be. Perhaps a phantom parent page that throws an error whenever a reference has been made or an invalid character figuring in a parent page name?


                    New Around Here

                      Hi Timo - finally your suggestion regarding other module instances on the page helped me find a temporary workaround solution. Inspecting the values in the Tabmodules table for a tab provided with the problem in question - the dnn.modulemanager in edit node throwing errors at  dnn.dnnModuleDialog.apply and handleNewModuleFromCookie methods - I found that some of the existing modules had a value in the CacheMethod column of 'MemoryModuleCachingProvider'. Tabs without any dnn.modulemanager issues only had NULL values in this field.

                      So changing field values in the CacheMethod column in tabmodules table of the concerned tab from MemoryModuleCachingProvider to NULL solved the problem.
                      It works - which is fine - but it doesn't make that much sence. Why would a CacheMethod value of MemoryModuleCachingProvider be invalid?

                      You are not authorized to post a reply.

                      These Forums are dedicated to the discussion of DNN Platform.

                      For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

                      1. If you have (suspected) security issues, please DO NOT post them in the forums but instead follow the official DNN security policy
                      2. No Advertising. This includes the promotion of commercial and non-commercial products or services which are not directly related to DNN.
                      3. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
                      4. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
                      5. No Flaming or Trolling.
                      6. No Profanity, Racism, or Prejudice.
                      7. Site Moderators have the final word on approving / removing a thread or post or comment.
                      8. English language posting only, please.

                      Would you like to help us?

                      Awesome! Simply post in the forums using the link below and we'll get you started.

                      Get Involved