• Login
  • Register

DNN Forums

A community discussion page. We're starting from scratch, so...let's get the party started!

Page Weight and Speed

You are not authorized to post a reply.
Sort:
Page 2 of 2 << < 12


Basic Member


Posts:61
Basic Member

    Sorry for the late reply, but it took longer than expected to get all the modules ported to 9.4.1.

    After the upgrade we now get a double B rating on gtmetrix, instead of double A, which is better than I expected. Before we had moved all CSS and JS to the CDN and now that stuff is on the local server again, for example. I hope to get to optimizing it during this week. Am happy that it's all working for now. :)

    Did you try out the Client Resource Management? You can find it in Persona Bar -> Settings -> Servers -> Server Settings -> Performance -> Enable Composite Files. I haven't tried it yet but it is supposed to combine CS and JS files to reduce the number of requests. I see that we have 25 requests now oposed to 14 before the upgrade. Enabling this option should reduce it hopefully. There is also options to automatically minify CS and JS files, a task that I had to perform manually with the old DNN version.

    Andreas



    Basic Member


    Posts:61
    Basic Member

      Not bad. After enabling composite files and minification of CSS and JS files (and increasing the version counter), it is back to an AB rating on GTMetrix. The 25 requests are now down to 17. That was easy. :) More to follow.



      Basic Member


      Posts:61
      Basic Member

        After offloading stuff like the company logo (logo.ascx), the flags from our Catalook language switcher and some more images to the CDN it is back to AA rating. The scripts are still loaded from the site directly, I will have a look at those later.


        New Member


        Posts:5
        New Member

          Cool, thanks for the replies!

          Yeah, CRM is enabled on all of my results.
          Speaking of which: there's a bug that adds the cdv=### suffix to CDNs as well rendering them completly useless. I'm still having that issue on my live site (upgraded numerous times from 7.4.2 to 9.4.2) but not on a fresh installation.

          Regards,
          Alois Krichmayr
          www.sierzega.com
          You are not authorized to post a reply.
          Page 2 of 2 << < 12

          These Forums are dedicated to discussion of DNN Platform.

          For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

          1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
          2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
          3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
          4. No Flaming or Trolling.
          5. No Profanity, Racism, or Prejudice.
          6. Site Moderators have the final word on approving / removing a thread or post or comment.
          7. English language posting only, please.

          Would you like to help us?

          Awesome! Simply post in the forums using the link below and we'll get you started.

          Get Involved