• Login
  • Register

DNN Forums

A community discussion page. We're starting from scratch, so...let's get the party started!

Home page of second language doesn't take the theme

You are not authorized to post a reply.
Sort:


New Member


Posts:3
New Member

    I've enabled localization (site setup > languages > added a second language) and got it up and running for all pages...duplicating the pages and modules with translated versions.

    However, when I installed a custom theme it looked good only until I switched into the second language (clicking the little flag) and then the home page of the second language was back to xcillion.  The other pages all reflected the custom theme I had enabled.

    I could just copy my custom theme into the xcillion folder but that seems like a poor hack of a solution... especially for other sites on the server that could be using that xcillion theme.

    Any ideas?



    Basic Member


    Posts:28
    Basic Member

      When you create a new language, DNN basically creates a new site. So, in the site settings and/or page settings of another language, you have to appoint the desired theme.


      Advanced Member


      Posts:186
      Advanced Member

        sorry Tycho, but you are totally wrong. A site being localized always remains a single website.
        When adding a language, a domain alias is added and a language specific set of site settings.<
        When enabling content localization, a copy of every language specific page is created with copies of all the modules on the pages.
        Back to the original question:
        The default skin and container applie to view and edit display of site pages are site settings. If you want to change skin for each language you need to switch to it and apply the switched theme again.


        New Member


        Posts:3
        New Member

          Posted By Sebastian Leupold on 08 Jan 2020 06:19 PM
          Back to the original question:
          The default skin and container applie to view and edit display of site pages are site settings. If you want to change skin for each language you need to switch to it and apply the switched theme again.

          I'll try again to explain.

          This is how it works for me except... I apply my custom theme in English (the original site language) and the theme successfully applies to all English pages. (good so far)

          When I switch to German and apply the custom theme, it applies successfully to all the German pages EXCEPT the home page.

          I have disabled/re-enabled multiple times and tried with other themes.  All themes behave in a similar fashion -- the German home page only displays Xcillion while the other pages pick up the new theme.

          Weird... Is there a proper way I can recreate the German home page? Do I have to do it from within the localization features (I created this site a while ago and it has been using Xcillion for the months since then...so I'm forgetting exactly the process).

          Thanks

           

           



          Advanced Member


          Posts:244
          Advanced Member

            By default the Home page has Xcillion theme in the page settings. So, you could install theme-xyz, make it the default of the website and it still could show the Xcillion theme....
            Can you verify the page settings of the German Home?
            Tjep's digital agencyRegards,
            Tycho de Waard

            Tjep's digital agency
            We just love DNN
            https://www.tjeps.com


            Advanced Member


            Posts:186
            Advanced Member

              In other words: the home page of your site has - by default - a different skin version applied (Xillion > home), which is copied with the page, when copying all pages for the second language. In this case, you need to edit the skin in page settings and apply the home skin from your theme.


              New Member


              Posts:3
              New Member

                I could have solved this problem quickly with DNN5 but I haven't kept up to date and believe it or not, my big problem was finding the setting.

                I'm glad it was something simple and not a localization problem at all.
                Thanks for helping me get the hang of the "new" ui. I just needed a the encouragement to know that the setting was still there somewhere.
                You are not authorized to post a reply.

                These Forums are dedicated to discussion of DNN Platform.

                For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

                1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
                2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
                3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
                4. No Flaming or Trolling.
                5. No Profanity, Racism, or Prejudice.
                6. Site Moderators have the final word on approving / removing a thread or post or comment.
                7. English language posting only, please.

                Would you like to help us?

                Awesome! Simply post in the forums using the link below and we'll get you started.

                Get Involved