• Login
  • Register

DNN Forums

Ask questions about your website to get help learning DNN and help resolve issues.

Installwizard hanging while Installation

You are not authorized to post a reply.
Sort:
Page 1 of 212 > >>


New Member


Posts:6
New Member

    Hello Forum

    I've setup a brand new Installation of the actually DNN version. All works fin until Step 2 (continue Installation....after Step 1 given Account names...SQL etc.). The Process hang with the description "...failure. The Applicatinpool has to start into the integrated modus" . So, now i changed in IIS the Pool to "integrated" . Restart the Pool...Start from new the IIS and run the Installwizard....but the website still jump to the point descript above. So whats the solution to finaly setup the website ? Any Ideas ?

    Thanks for your support
    rte



    Veteran Member


    Posts:577
    Veteran Member

      Have you checked the installation log files? The solution can be found there, most propably...

      Happy DNNing!
      Michael

      Michael Tobisch
      DNN★MVP

      dnnWerk Austria
      DNN Connect


      New Member


      Posts:6
      New Member

        Hi Michael

        Here the Log-Entry:

        2021-07-21 09:23:59.413+02:00 [MYServer][D:3][T:9][ERROR] DotNetNuke.ComponentModel.ProviderInstaller - System.Configuration.ConfigurationErrorsException: Could not load provider DNNConnect.CKEditorProvider.CKHtmlEditorProvider, DNNConnect.CKEditorProvider
        2021-07-21 09:24:00.606+02:00 [MYServer][D:3][T:9][ERROR] DotNetNuke.Data.PetaPoco.PetaPocoHelper - [1] Error executing SQL: ;Exec dbo.GetDatabaseVersion
        Could not find stored procedure 'dbo.GetDatabaseVersion'.

        Not really helpful for me, but maybe you have a idea for it ?

        Thanks
        Remo



        Veteran Member


        Posts:1079
        Veteran Member

          Which version of DNN are you trying to install?
          Have you checked that all of the prerequisites have been met?

          Is this on a production type server on on a development server. If the latter, you might want to use nvQuickSite to get it installed.
          Joe Craig
          DNN MVP
          Patapsco Research Group


          New Member


          Posts:6
          New Member

            Vers. 9.1 ....it is a internal Webserver on Win 2019SRV with SQL2017.

            And yes i try to install with nvQuickSite...but it gives me always Permission-Errors when i try to install/generate a Website. Thats why i choos to install manual....



            Veteran Member


            Posts:385
            Veteran Member

              most likely, the SQL Server user does not have DbOwner permission for the database. I'd clear the files and the database and start from scratch.


              Veteran Member


              Posts:577
              Veteran Member

                There might be two issues:

                1) did you unblock the ZIP file before extracting?
                2) the application pool needs modify permissions in the file system (folder, where you install DNN and sub-folders) and membership in the db_owner role for the database. (Please read Secure your DNN Database by some simple steps (dnncommunity.org) to learn how to reduce the database permissions later.)

                Did you check that?

                Happy DNNing!
                Michael

                 

                Michael Tobisch
                DNN★MVP

                dnnWerk Austria
                DNN Connect


                New Member


                Posts:6
                New Member

                  i already did this steps, but unfortunatly when i restart IIS and start the installwizard.aspx...it will go automatically to step 2 where it hangs. it doesn't start the installwizard from new. where/how can i reset the installwizard ?



                  Veteran Member


                  Posts:385
                  Veteran Member

                    you might need to delete all files and start from scratch.


                    Veteran Member


                    Posts:1079
                    Veteran Member

                      Delete everything, including directories and databases. Clear it all out.

                      Check the prerequisites ... AGAIN. And make sure that you've got the right version of .NET Framework.

                      Then, try installing again with nvQuickSite. But, double check all of the nvQuickSite settings first. And, try using Windows Authentication for the SQL Server connection.
                      Joe Craig
                      DNN MVP
                      Patapsco Research Group
                      You are not authorized to post a reply.
                      Page 1 of 212 > >>

                      These Forums are dedicated to discussion of DNN Platform.

                      For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

                      1. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
                      2. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
                      3. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
                      4. No Flaming or Trolling.
                      5. No Profanity, Racism, or Prejudice.
                      6. Site Moderators have the final word on approving / removing a thread or post or comment.
                      7. English language posting only, please.

                      Would you like to help us?

                      Awesome! Simply post in the forums using the link below and we'll get you started.

                      Get Involved