• Login
  • Register

DNN Forums

Ask questions about your website to get help learning DNN and help resolve issues.

Uploading files

You are not authorized to post a reply.
Sort:


New Around Here


Posts:18
New Around Here

    Hi!
    I have been updateing a DNN site from version 9.10.2 to version 9.11.0.

    No errors in the update process and Telerik was removed successfully. The site works fine after update, but I can no longer upload files in Site Assets. The message shown is "Bad request".

    In the site I can choose to use Swedish or English language. In the English part of the site the upload works, but in the Swedish part of the site it does not work.

    In the "Server / Server Settings / LOGGS I found:
    DotNetNuke.Web.InternalServices.FileUploadController - System.InvalidOperationException: Bad Request at DotNetNuke.Web.InternalServices.FileUploadController.UploadFile(Stream stream, Int32 portalId, UserInfo userInfo, String folder, String filter, String fileName, Boolean overwrite, Boolean isHostPortal, Boolean extract, String validationCode)

    Does any of you in this forum know what the cause is?

    //Peter



    Veteran Member


    Posts:582
    Veteran Member

      Have you tried reapplying the necessary file permissions to your website folder? Generally, the user account specified in the application pool for your website should have Modify/Full permission, and IIS_IUSRS should have read-only permissions (for static files like JS, images, etc.).
      Will Strohl

      Upendo Ventures DNN experts since 2003
      Official provider of the DNN-based E-Commerce w/ Hotcakes Commerce Cloud and SLA support


      Veteran Member


      Posts:582
      Veteran Member

        Oh, and if you choose to reapply the permissions, you'll likely need to recycle the application pool as well.  :) 

        Will Strohl

        Upendo Ventures DNN experts since 2003
        Official provider of the DNN-based E-Commerce w/ Hotcakes Commerce Cloud and SLA support


        New Around Here


        Posts:18
        New Around Here

          Yes Will, I have tried that, just before I did read your input :) .

          Unfortunately I was not able to fulfill the task due to errors like:

          failed to enumerate objects in the container ... Access denied.

          I could see that the files giving errors are new files from the upgrade and these files has the "owner" = the specified application pool.

          When I try to update the permissions I am logged in as admin user on the server via a remote desktop. All older files has "owner" = the admin user, same as I was using when I when I was working on the server.

          Perhaps I need to change the "owner" of ALL files in the website folder to the admin user, before I try to change the permissions?

          I do not know how to do that. Can you help me out?

          All the best!
          //Peter



          New Around Here


          Posts:18
          New Around Here

            A few more thoughts,

            I have not yet changed the owner of any file or folder, but all the folders and files I have inspected manually all have the permisson "Modify" for the apppool-user. 

            I have also seen that when I use the english part of the website, I have no problems uploading files in Site Assets. When I try uploading using the Site Assets in the Swedish part of the website I get the error.

            //Peter



            Veteran Member


            Posts:582
            Veteran Member

              Posted By Smuggler on 10/18/2022 12:19 AM

              I have also seen that when I use the english part of the website, I have no problems uploading files in Site Assets. When I try uploading using the Site Assets in the Swedish part of the website I get the error.

              Thank you for continuing to update this post with details.  

              At this time, it sounds like this might be a bug related to localization.  I found a few other recently reported bugs with the resource manager.  Do any of these look like they might be related?  

              If not, then more information is needed.  You'll need to determine if there are any underlying errors that are happening and use those to create a new issue in GitHub to resolve this localization bug.  :(  

              The following video can help you determine where and how to gather that information, except for whatever might be in the web browser console.  

              https://www.youtube.com/watch?v=uyN...p;index=17

              This page briefly describes the web developer console.  

              https://balsamiq.com/support/faqs/browserconsole/

               

              Will Strohl

              Upendo Ventures DNN experts since 2003
              Official provider of the DNN-based E-Commerce w/ Hotcakes Commerce Cloud and SLA support


              New Around Here


              Posts:18
              New Around Here

                I have looked among reported issues but was not able to see any report beeing correlated to the problem I have seen.

                I have now reported a bug with all information I have found on GitHub.

                Will, thanks for your input and support!

                All the best
                //Peter

                You are not authorized to post a reply.

                These Forums are dedicated to discussion of DNN Platform.

                For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

                1. If you have (suspected) security issues, please do not post them in the forums but send an email to [email protected]
                2. No Advertising. This includes promotion of commercial and non-commercial products or services which are not directly related to DNN.
                3. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
                4. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
                5. No Flaming or Trolling.
                6. No Profanity, Racism, or Prejudice.
                7. Site Moderators have the final word on approving / removing a thread or post or comment.
                8. English language posting only, please.

                Would you like to help us?

                Awesome! Simply post in the forums using the link below and we'll get you started.

                Get Involved