DNN Forums

Ask questions about your website to get help learning DNN and help resolve issues.

Issue updating DNN to last version.

You are not authorized to post a reply.

New Around Here

    I received an error with HTML module when upgrade DNN to version 9.11.0 from version 9.10.2. After DNN is upgraded just HTML module keep version 9.10.2 and stopped work.

    After some checking, trying to instal just HTML module, for some reason install is trying to run scripts from file 03.00.00.SqlDataProvider. and some stored procedures are deleted because those old scripts delete procedures to create again.

    It appears module have some reference in DB or some File that suggest to installer run all scripts from 03.00.00 version which is incorrect because module already is in version 9.10.2

    I found module version information in Package, DesktopModules and Assemblies databases and updated from 9.3.2 to 9.10.2 and try to update the module but Im still receiving the error.

    Where I can found version reference used for installer to run SqlDataProvider scripts.



    Veteran Member

      Whoa... This is an interesting issue.  I've never heard of this happening before. 

      Are you on DNN Platform or Evoq? 

      Also, do you have any idea if the integrity of the website was okay before the upgrade?  You can check that via Security Analyzer in the persona bar.  

      Example:  https://app.screencast.com/n1hPnTNXKD1lR

      Due to the uniqueness of this issue, I'm wondering if there are any core code changes made, or something worse.  I'd suggest looking through the security analyzer to see if anything is highlighted - specifically the integrity checks.  

      New Around Here

        Hi Will thanks for your response.

        Im using DNN Platform and I have restored to version 9.10.2, checked security analyzer but nothing weird was found. As additional information, database was moved between servers generating scripts, not with backup, according to DB Server version limitation, so Im pretty sure some information could be lost or changed in that process. Im 100% sure code was not touched or modified.

        Tried again for a couple of times to upgrade to version 9.11.0 and error is the same. Basically script in file 03.00.00.SqlDataProvider delete stored procedures AddHtmlText, UpdateHtmlText and GetHtmlText and then try to create again but fails because fields in html tables are not the same as last version 9.10.2, so after that error, html module just show information but editing is not allowed because those stored procedures where deleted.

        I would like to know how installer obtain version for module when install, and decides which scripts to run, maybe i can change some value on DB or some file to try to solve. I tried to find some clues on code files but honestly is a little hard.

        For now, I have recreated deleted stored procedures and html module is working but still keeps in version 9.10.2 when site is already upgraded to 9.11.0. I would like to upgrade HTML module to version 9.11.0 too.

        Thanks for your help

        Veteran Member

          Well, how it grabs the version number may not be as important as the amount of time and effort it might take to troubleshoot this and figure out what happened. For example, depending on how large the website is and how bad the troubleshooting becomes, it might be a better use of time to rebuild the website and then import the content.  

          Did you use a bacpac for the database move or another scripting process?  It sounds like you might need to perform a diff on the database schema and objects.  Tools like SQL Compare makes that easy, if you happen to have the budget for it.  

          New Around Here

            Well, I have tried a lot of options and finally I found the issue, and was just the name for the module in tables DesktopModules and Packages.

            Real name for Html Module in version 9.10.2 is DNN_Html, but in database was just HTML, i suppose installer can't found module to be upgrade, so needs to install from scratch, thats why run all scripts.

            I updated name DNN_Html and checked version for module in tables mentioned, and upgrade worked.

            This site was upgraded from version 8.X.X a long time ago, so I think some time Module Name was just HTML and never was updated.

            Thanks anyway for your time.

            Veteran Member

              Wow... That's so great that this was that simple this time! 😎 

              If it were me, I'd still want to do a very thorough diff/compare in the file system and database.  If that was an issue, you're likely to run into MANY more as time goes, and/or not be able to upgrade.  These are all risks at the moment.  :(  

              You are not authorized to post a reply.

              These Forums are dedicated to the discussion of DNN Platform.

              For the benefit of the community and to protect the integrity of the ecosystem, please observe the following posting guidelines:

              1. If you have (suspected) security issues, please DO NOT post them in the forums but instead follow the official DNN security policy
              2. No Advertising. This includes the promotion of commercial and non-commercial products or services which are not directly related to DNN.
              3. No vendor trolling / poaching. If someone posts about a vendor issue, allow the vendor or other customers to respond. Any post that looks like trolling / poaching will be removed.
              4. Discussion or promotion of DNN Platform product releases under a different brand name are strictly prohibited.
              5. No Flaming or Trolling.
              6. No Profanity, Racism, or Prejudice.
              7. Site Moderators have the final word on approving / removing a thread or post or comment.
              8. English language posting only, please.

              Would you like to help us?

              Awesome! Simply post in the forums using the link below and we'll get you started.

              Get Involved